Swap master doesn't allow more than 1 slave per terminal?

#1
I have a setup of 5 brokers. All of them are running multiple chart windows
Image
I have corresponding counter pairs setup across different other brokers the same way.

On the master, I can see all the brokers connected successfully so I was placing a trade for a broker that has 4 charts running and the other one that has two charts running with the slave attached. Here's what I've got:
Image
So on the picture, despite the slaves were attached to different charts - they all executed the same orders and therefore I'm getting the setup above with totally unwanted trades. I'm not sure anyone has tried this setup so far, but I appreciate some help here as my assumption would be the following.

* The slave is attached to a specific chart where it gets all required information which it passes upon order creation from the master.
* Once an order is created on master - one and only one slave executes an order in the target terminal that actually matches the symbol - not like in the screenshot above.

appreciate this fix implemented as this prevents me from moving forward with the current setup as I can only test 1 pair per 2 brokers, which doesn't give me enough options to play around, unfortunately :(

Many Thanks!

Re: Swap master doesn't allow more than 1 slave per terminal?

#2
Hello aizet.
What you describe does not require fixing. Setting it up correct will do the trick. ;)

So on the picture, despite the slaves were attached to different charts - they all executed the same orders and therefore I'm getting the setup above with totally unwanted trades. I'm not sure anyone has tried this setup so far, but I appreciate some help here as my assumption would be the following.


You don't need to run multiple Slave on one terminal for one and the same terminal. You only need one for every portfolio. Example: If you run a simple portfolio with two brokers you need on one terminal a Master and Slave unit (both linked by portfolio color) and on the second terminal another Slave unit. Again the unit must be linked.
Now, even if you run a portfolio with many different instruments and trades, you still need only one Slave instance. It is designed this way to make sure the number of running instances is as low as possible. Otherwise the software would use a lot more computer memory.

To solve the situation you have, do the following:
  • Remove duplicated and linked Slave units (or set them back to Info).
  • Go back to the Master unit and then place the trades again.

Please, next time before you claim that something does not work, consult the manual. Because a button or function does not do what you think it does, it does not automatically mean that something does not work.

Alexander